Apple StoreApple today released Pro Application Support 4.0 which improves general user interface reliability for Apple’s professional applications and is recommended for all users of:
• Final Cut Studio
• Final Cut Pro
• Motion
• Soundtrack Pro
• Soundtrack
• DVD Studio Pro
• Aperture
• Final Cut Express HD
• Logic Pro
• Logic Express

Mac OS X 10.4 or later required.

Pro Application Support 4.0 is available via Software Update and also as a standalone installer.

More info and download link (7.6MB) here.

[Thanks to MacDailyNews Reader “Jim – TIV” for the heads up.]